Problem:
I have lost the combination to my safe. How do I recover?

Cause:
Changed combination to an unknown code. Recently purchased safe from third party.

Solution:
You could possibly be in “Penalty Time.” Please wait 15 minutes and retry your code.

Please contact the safe manufacture to see if they have any information about the lock on that safe. You will need to reference the safe serial number when you call in. The safe company may be able to provide you with and Management Reset Code (MRC). This code will set your lock back to factory default 123456#

Applicable to:
6120, 6123, Titan, Spartan, MPP

Close